summaryrefslogtreecommitdiff
path: root/src/gui/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2024-07-21 23:04:53 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2024-07-21 23:04:53 (GMT)
commitd1874bdcaf52717ebf6f808010d275ca1f1693f3 (patch)
treec47941b305f6d4867e91edbb0b90e69f63778072 /src/gui/Makefile.am
parente4ccb9e56e822628e299527fee0b7325f0d25662 (diff)
Separate the GTK application and the GTK main window.
Diffstat (limited to 'src/gui/Makefile.am')
-rw-r--r--src/gui/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/gui/Makefile.am b/src/gui/Makefile.am
index 4197989..5ec43d2 100644
--- a/src/gui/Makefile.am
+++ b/src/gui/Makefile.am
@@ -29,7 +29,9 @@ libgui_la_CFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS)
libgui4_la_SOURCES = \
panel-int.h \
panel.h panel.c \
- resources.h resources.c
+ resources.h resources.c \
+ window-int.h \
+ window.h window.c
libgui4_la_LIBADD = \
core/libguicore4.la \
@@ -47,7 +49,8 @@ SUBDIRS = core panels # dialogs menus panels tb
RES_FILES = \
- style.css
+ style.css \
+ window.ui
resources.c: gresource.xml $(RES_FILES)
glib-compile-resources --target=$@ --sourcedir=$(srcdir) --generate-source --c-name gui gresource.xml