summaryrefslogtreecommitdiff
path: root/src/gui/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2024-07-20 23:23:43 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2024-07-20 23:23:43 (GMT)
commite4ccb9e56e822628e299527fee0b7325f0d25662 (patch)
tree10d5eb35fad4ba01b757d4c403c912f209eacb3e /src/gui/Makefile.am
parent9d0d5edf372a9f681bbfd0a3639ee8fc367ce96d (diff)
Prepare a welcome screen.
Diffstat (limited to 'src/gui/Makefile.am')
-rw-r--r--src/gui/Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/src/gui/Makefile.am b/src/gui/Makefile.am
index da46844..4197989 100644
--- a/src/gui/Makefile.am
+++ b/src/gui/Makefile.am
@@ -27,10 +27,13 @@ libgui_la_CFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS)
libgui4_la_SOURCES = \
+ panel-int.h \
+ panel.h panel.c \
resources.h resources.c
libgui4_la_LIBADD = \
- core/libguicore4.la
+ core/libguicore4.la \
+ panels/libguipanels4.la
libgui4_la_CFLAGS = $(LIBGTK4_CFLAGS)
@@ -40,10 +43,13 @@ devdir = $(includedir)/chrysalide/$(subdir:src/%=core/%)
dev_HEADERS = $(libgui_la_SOURCES:%c=)
-SUBDIRS = core # dialogs menus panels tb
+SUBDIRS = core panels # dialogs menus panels tb
-resources.c: gresource.xml $(UI_FILES)
+RES_FILES = \
+ style.css
+
+resources.c: gresource.xml $(RES_FILES)
glib-compile-resources --target=$@ --sourcedir=$(srcdir) --generate-source --c-name gui gresource.xml
resources.h: gresource.xml
@@ -52,4 +58,4 @@ resources.h: gresource.xml
CLEANFILES = resources.h resources.c
-EXTRA_DIST = gresource.xml $(UI_FILES)
+EXTRA_DIST = gresource.xml $(RES_FILES)