summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a28f09b..13a6314 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,15 @@
-EXTRA_DIST = config.rpath config.rpath config.rpath ChangeLog
+BUILT_SOURCES = revision.h
+
+.svn:
+ @[ -d $@ ] || touch $@
+
+revision.h: .svn
+ @nb=`svn log . -l 1 -q | grep r | cut -d ' ' -f 1 | tr -d 'r'` ; \
+ sed -i "s/#define REVISION .*$$/#define REVISION $$nb/" $@ ; \
+ [ -f $< ] && rm $<
+
+EXTRA_DIST = config.rpath config.rpath config.rpath config.rpath ChangeLog
SUBDIRS = pixmaps src plugins