summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 300c970..5acf436 100644
--- a/configure.ac
+++ b/configure.ac
@@ -623,6 +623,20 @@ if test "x$enable_json_glib_support" = "xyes"; then
fi
+#--- Checks for libzip
+
+PKG_CHECK_MODULES(LIBZIP,libzip >= 1.7.3,[libzip_found=yes],[libzip_found=no])
+
+if test "$libzip_found" = "yes"; then
+ libzip_version=`pkg-config libzip --modversion`
+else
+ libzip_version='-'
+fi
+
+AC_SUBST(LIBZIP_CFLAGS)
+AC_SUBST(LIBZIP_LIBS)
+
+
#--- Checks for Python
if test "x$enable_debug" = "xyes"; then
@@ -912,6 +926,7 @@ echo The YAML support library..................... : $libyaml_version
echo The magic number recognition library......... : $libmagic_version
echo The high-performance matching library........ : $libhs_version
echo The JSON Parser for the GLib library......... : $libjsonglib_version
+echo The library for handling ZIP archives........ : $libzip_version
echo
echo Available Python programming language........ : $python3_version