summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 18 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 23e4e9b..2ff719a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -593,6 +593,16 @@ AC_SUBST(LIBHS_LIBS)
#--- Checks for json-glib-1.0
+AM_CONDITIONAL([BUILD_JSONGLIB_SUPPORT], [test "x$enable_jsonglib_support" = "xyes"])
+
+if test "x$BUILD_JSONGLIB_SUPPORT_TRUE" = "x"; then
+ # json-glib support is available and enabled
+ CPPFLAGS="$CPPFLAGS -DINCLUDE_JSONGLIB_SUPPORT"
+fi
+
+curl
+
+
PKG_CHECK_MODULES(LIBJSONGLIB,json-glib-1.0 >= 1.6.6,[libjsonglib_found=yes],[libjsonglib_found=no])
if test "$libjsonglib_found" = "yes"; then
@@ -601,8 +611,14 @@ else
libjsonglib_version='-'
fi
-AC_SUBST(LIBJSONGLIB_CFLAGS)
-AC_SUBST(LIBJSONGLIB_LIBS)
+if test "x$enable_json_glib_support" = "xyes"; then
+
+ AC_SUBST(LIBJSONGLIB_CFLAGS)
+ AC_SUBST(LIBJSONGLIB_LIBS)
+
+ true # empty if/then body not allowed
+
+fi
#--- Checks for Python