summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7a95ffd..1b7bdfa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -141,12 +141,18 @@ AC_SUBST(DEBUG_CFLAGS)
#-Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wpointer-arith -Wmissing-prototypes
-WARNING_FLAGS="-D_ISOC99_SOURCE -Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wpointer-arith -Wmissing-prototypes"
+WARNING_FLAGS="-Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wpointer-arith -Wmissing-prototypes"
#-Wcast-qual -Wconversion -Wsign-compare -Wdisabled-optimization
AC_SUBST(WARNING_FLAGS)
+# _XOPEN_SOURCE: strdup, snprintf
+# _ISOC99_SOURCE: INFINITY; NAN
+COMPLIANCE_FLAGS="-D_GNU_SOURCE"
+
+AC_SUBST(COMPLIANCE_FLAGS)
+
#--- Checks for GTK 2.0
PKG_CHECK_MODULES(LIBGTK,gtk+-2.0 >= 2.4.3,[libgtk_found=yes],[libgtk_found=no])