summaryrefslogtreecommitdiff
path: root/plugins/pychrysalide/glibext/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/pychrysalide/glibext/Makefile.am')
-rw-r--r--plugins/pychrysalide/glibext/Makefile.am19
1 files changed, 13 insertions, 6 deletions
diff --git a/plugins/pychrysalide/glibext/Makefile.am b/plugins/pychrysalide/glibext/Makefile.am
index 3a5fab2..6d3d746 100644
--- a/plugins/pychrysalide/glibext/Makefile.am
+++ b/plugins/pychrysalide/glibext/Makefile.am
@@ -1,14 +1,11 @@
-noinst_LTLIBRARIES = libpychrysaglibext.la
+noinst_LTLIBRARIES = libpychrysaglibext.la libpychrysaglibextui.la
# libpychrysaglibext_la_SOURCES = \
# binarycursor.h binarycursor.c \
# buffercache.h buffercache.c \
-# bufferline.h bufferline.c \
# configuration.h configuration.c \
-# linecursor.h linecursor.c \
-# linegen.h linegen.c \
-# module.h module.c
+# linecursor.h linecursor.c
# if BUILD_GTK_SUPPORT
@@ -38,6 +35,16 @@ libpychrysaglibext_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBPYTHON_INTERPRETER_CFLAGS)
-I$(top_srcdir)/src -DNO_IMPORT_PYGOBJECT
+libpychrysaglibextui_la_SOURCES = \
+ bufferline.h bufferline.c \
+ constants-ui.h constants-ui.c \
+ generator.h generator.c \
+ module-ui.h module-ui.c
+
+libpychrysaglibextui_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBPYTHON_INTERPRETER_CFLAGS) $(LIBPYGOBJECT_CFLAGS) \
+ -I$(top_srcdir)/src -DNO_IMPORT_PYGOBJECT
+
+
devdir = $(includedir)/chrysalide/$(subdir)
-dev_HEADERS = $(libpychrysaglibext_la_SOURCES:%c=)
+dev_HEADERS = $(libpychrysaglibext_la_SOURCES:%c=) $(libpychrysaglibextui_la_SOURCES:%c=)