summaryrefslogtreecommitdiff
path: root/src/arch/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/arch/Makefile.am')
-rw-r--r--src/arch/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/src/arch/Makefile.am b/src/arch/Makefile.am
index 127ca4c..6683854 100644
--- a/src/arch/Makefile.am
+++ b/src/arch/Makefile.am
@@ -13,18 +13,17 @@ noinst_LTLIBRARIES = libarch.la libarchui.la
# libarch_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS)
# libarch_la_LIBADD = \
-# instructions/libarchinstructions.la \
# operands/libarchoperands.la
-# instruction-int.h \
-# instruction.h instruction.c \
#
# processor-int.h \
# processor.h processor.c \
#
libarch_la_SOURCES = \
+ instruction-int.h \
+ instruction.h instruction.c \
operand-int.h \
operand.h operand.c \
register-int.h \
@@ -34,10 +33,13 @@ libarch_la_SOURCES = \
libarch_la_CFLAGS = $(LIBGOBJ_CFLAGS)
libarch_la_LIBADD = \
+ instructions/libarchinstructions.la \
operands/libarchoperands.la
libarchui_la_SOURCES = \
+ instruction-ui-int.h \
+ instruction-ui.h instruction-ui.c \
operand-ui-int.h \
operand-ui.h operand-ui.c
@@ -52,5 +54,4 @@ devdir = $(includedir)/chrysalide/$(subdir:src/%=core/%)
dev_HEADERS = $(libarch_la_SOURCES:%c=) $(libarchui_la_SOURCES:%c=)
-#SUBDIRS = instructions operands
-SUBDIRS = operands
+SUBDIRS = instructions operands