summaryrefslogtreecommitdiff
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index 83c754c..24929e7 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -62,10 +62,24 @@ libcommon4_la_SOURCES = \
pathname.h pathname.c \
shuffle.h shuffle.c \
sort.h sort.c \
+ szbin.h \
xdg.h xdg.c
+if BUILD_CURL_SUPPORT
+
+libcommon4_la_SOURCES += \
+ curl.h curl.c
+
+endif
+
libcommon4_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBSSL_CFLAGS)
+if BUILD_CURL_SUPPORT
+
+libcommon4_la_CFLAGS += $(LIBCURL_CFLAGS)
+
+endif
+
devdir = $(includedir)/chrysalide/$(subdir:src/%=core/%)