summaryrefslogtreecommitdiff
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index 687cb63..d09b661 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -58,7 +58,6 @@ libcommon4_la_SOURCES = \
extstr.h extstr.c \
fnv1a.h fnv1a.c \
io.h io.c \
- json.h json.c \
leb128.h leb128.c \
macros.h \
packed.h packed.c \
@@ -75,6 +74,13 @@ libcommon4_la_SOURCES += \
endif
+if BUILD_JSONGLIB_SUPPORT
+
+libcommon4_la_SOURCES += \
+ json.h json.c
+
+endif
+
libcommon4_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBSSL_CFLAGS) $(LIBJSONGLIB_CFLAGS)
if BUILD_CURL_SUPPORT
@@ -83,6 +89,12 @@ libcommon4_la_CFLAGS += $(LIBCURL_CFLAGS)
endif
+if BUILD_JSONGLIB_SUPPORT
+
+libcommon4_la_CFLAGS += $(LIBJSONGLIB_CFLAGS)
+
+endif
+
devdir = $(includedir)/chrysalide/$(subdir:src/%=core/%)