summaryrefslogtreecommitdiff
path: root/src/format/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/format/Makefile.am')
-rw-r--r--src/format/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/src/format/Makefile.am b/src/format/Makefile.am
index 99afa2e..acc849b 100644
--- a/src/format/Makefile.am
+++ b/src/format/Makefile.am
@@ -1,2 +1,19 @@
-SUBDIRS = elf
+lib_LIBRARIES = libformat.a
+
+libformat_a_SOURCES = \
+ exe_format.h exe_format.c \
+ exe_format-int.h \
+ dbg_format.h dbg_format.c \
+ dbg_format-int.h
+
+libformat_a_CFLAGS = $(AM_CFLAGS)
+
+
+INCLUDES =
+
+AM_CPPFLAGS =
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS)
+
+SUBDIRS = dwarf elf