summaryrefslogtreecommitdiff
path: root/src/glibext/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/glibext/Makefile.am')
-rw-r--r--src/glibext/Makefile.am33
1 files changed, 22 insertions, 11 deletions
diff --git a/src/glibext/Makefile.am b/src/glibext/Makefile.am
index ba4e3fa..e2c9d69 100644
--- a/src/glibext/Makefile.am
+++ b/src/glibext/Makefile.am
@@ -4,10 +4,6 @@ BUILT_SOURCES = chrysamarshal.h chrysamarshal.c resources.h resources.c
noinst_LTLIBRARIES = libglibext4.la libglibextui.la # libglibext.la
libglibext_la_SOURCES = \
- buffercache-int.h \
- buffercache.h buffercache.c \
- bufferline.h bufferline.c \
- chrysamarshal.h chrysamarshal.c \
comparison-int.h \
comparison.h comparison.c \
configuration-int.h \
@@ -17,11 +13,9 @@ libglibext_la_SOURCES = \
gbinarycursor.h gbinarycursor.c \
gbinportion-int.h \
gbinportion.h gbinportion.c \
- displayoptions.h displayoptions.c \
glinecursor-int.h \
glinecursor.h glinecursor.c \
gnhash.h gnhash.c \
- linecolumn.h linecolumn.c \
notifier.h \
objhole.h \
proto.h \
@@ -35,12 +29,10 @@ libglibext_la_SOURCES = \
if BUILD_GTK_SUPPORT
libglibext_la_SOURCES += \
- bufferview.h bufferview.c \
gloadedpanel-int.h \
gloadedpanel.h gloadedpanel.c \
named-int.h \
- named.h named.c \
- widthtracker.h widthtracker.c
+ named.h named.c
endif
@@ -51,6 +43,7 @@ libglibext_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS)
libglibext4_la_SOURCES = \
+ chrysamarshal.h chrysamarshal.c \
helpers.h
libglibext4_la_CFLAGS = $(TOOLKIT_CFLAGS)
@@ -60,19 +53,37 @@ RES_FILES = \
tokenstyle.css
libglibextui_la_SOURCES = \
+ buffercache-int.h \
+ buffercache.h buffercache.c \
+ bufferline-int.h \
+ bufferline.h bufferline.c \
+ bufferview-int.h \
+ bufferview.h bufferview.c \
+ generator-int.h \
+ generator.h generator.c \
+ linecolumn.h linecolumn.c \
+ linetoken.h linetoken.c \
+ options-int.h \
+ options.h options.c \
tokenstyle-int.h \
tokenstyle.h tokenstyle.c \
- resources.h resources.c
+ resources.h resources.c \
+ widthtracker-int.h \
+ widthtracker.h widthtracker.c
libglibextui_la_CFLAGS = $(LIBGTK4_CFLAGS)
+libglibextui_la_LIBADD = \
+ generators/libglibextgenerators.la \
+ options/libglibextoptions.la
+
devdir = $(includedir)/chrysalide/$(subdir:src/%=core/%)
dev_HEADERS = $(libglibext_la_SOURCES:%c=)
-#SUBDIRS = generators
+SUBDIRS = generators options
chrysamarshal.h: chrysamarshal.list