summaryrefslogtreecommitdiff
path: root/src/glibext/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/glibext/Makefile.am')
-rw-r--r--src/glibext/Makefile.am26
1 files changed, 24 insertions, 2 deletions
diff --git a/src/glibext/Makefile.am b/src/glibext/Makefile.am
index ac8668c..336c121 100644
--- a/src/glibext/Makefile.am
+++ b/src/glibext/Makefile.am
@@ -1,7 +1,7 @@
-BUILT_SOURCES = chrysamarshal.h chrysamarshal.c
+BUILT_SOURCES = chrysamarshal.h chrysamarshal.c resources.h resources.c
-noinst_LTLIBRARIES = libglibext4.la # libglibext.la
+noinst_LTLIBRARIES = libglibext4.la libglibextui.la # libglibext.la
libglibext_la_SOURCES = \
buffercache-int.h \
@@ -58,6 +58,17 @@ libglibext4_la_SOURCES = \
libglibext4_la_CFLAGS = $(TOOLKIT_CFLAGS)
+RES_FILES = \
+ tokenstyle.css
+
+libglibextui_la_SOURCES = \
+ tokenstyle-int.h \
+ tokenstyle.h tokenstyle.c \
+ resources.h resources.c
+
+libglibextui_la_CFLAGS = $(LIBGTK4_CFLAGS)
+
+
devdir = $(includedir)/chrysalide/$(subdir:src/%=core/%)
dev_HEADERS = $(libglibext_la_SOURCES:%c=)
@@ -72,3 +83,14 @@ chrysamarshal.h: chrysamarshal.list
chrysamarshal.c: chrysamarshal.list
echo "#include <$(subst .c,.h,$@)>" > $@
glib-genmarshal --body $< >> $@
+
+resources.c: gresource.xml $(RES_FILES)
+ glib-compile-resources --target=$@ --sourcedir=$(srcdir) --generate-source --c-name glibext gresource.xml
+
+resources.h: gresource.xml
+ glib-compile-resources --target=$@ --sourcedir=$(srcdir) --generate-header --c-name glibext gresource.xml
+
+
+CLEANFILES = resources.h resources.c
+
+EXTRA_DIST = gresource.xml $(RES_FILES)