summaryrefslogtreecommitdiff
path: root/src/glibext/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/glibext/Makefile.am')
-rw-r--r--src/glibext/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/glibext/Makefile.am b/src/glibext/Makefile.am
index d5235c8..b6f100b 100644
--- a/src/glibext/Makefile.am
+++ b/src/glibext/Makefile.am
@@ -1,7 +1,10 @@
+BUILT_SOURCES = chrysamarshal.h chrysamarshal.c
+
noinst_LTLIBRARIES = libglibext.la
libglibext_la_SOURCES = \
+ chrysamarshal.h chrysamarshal.c \
delayed-int.h \
delayed.h delayed.c \
gbufferline.h gbufferline.c \
@@ -21,3 +24,11 @@ AM_CPPFLAGS =
AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
SUBDIRS =
+
+
+chrysamarshal.h: chrysamarshal.list
+ glib-genmarshal --header $< > $@
+
+chrysamarshal.c: chrysamarshal.list
+ echo "#include <$(subst .c,.h,$@)>" > $@
+ glib-genmarshal --body $< >> $@