summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2024-01-28 21:27:09 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2024-01-28 21:27:09 (GMT)
commit24945cea340b7b0ca0fe2ccad7b67519dda1c1bd (patch)
tree97ad3364db5f5f5ab0574310c061f75f42418f0c /configure.ac
parent3231349bac6aae1f236416a8a51f41caccc38961 (diff)
Implement a basic support for Hyperscan.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 55e8f65..cfb94bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -541,6 +541,20 @@ if test "x$enable_magic_support" = "xyes"; then
fi
+#--- Checks for Hyperscan
+
+PKG_CHECK_MODULES(LIBHS,libhs >= 5.4.9,[libhs_found=yes],[libhs_found=no])
+
+if test "$libhs_found" = "yes"; then
+ libhs_version=`pkg-config libhs --modversion`
+else
+ libhs_version='-'
+fi
+
+AC_SUBST(LIBHS_CFLAGS)
+AC_SUBST(LIBHS_LIBS)
+
+
#--- Checks for Python
if test "x$enable_debug" = "xyes"; then
@@ -822,6 +836,7 @@ echo The cryptography and SSL/TLS toolkit......... : $libssl_version
echo The client URL library....................... : $libcurl_version
echo The YAML support library..................... : $libyaml_version
echo The magic number recognition library......... : $libmagic_version
+echo The high-performance matching library........ : $libhs_version
echo
echo Available Python programming language........ : $python3_version