summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2022-09-22 21:09:49 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2022-09-22 21:09:49 (GMT)
commit430aad874900f525c67a5aa5de9e6012a64ff603 (patch)
treecaed7f7ee23290e44ca06c56baa7e9d7c60dff6b /configure.ac
parent735effa6ee2ebd22bf6421da71ed9aa541980130 (diff)
Fix runtime Python warnings for all # variants of formats.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b9377b2..32a9c05 100644
--- a/configure.ac
+++ b/configure.ac
@@ -434,7 +434,7 @@ if test "x$python3_cfg_binary" = "xyes"; then
LIBPYTHON_CFLAGS=`$pyprefix-config --cflags`
LIBPYTHON_LIBS=`$pyprefix-config --libs`
- LIBPYTHON_INTERPRETER_CFLAGS=`$pyprefix-config --cflags --embed`
+ LIBPYTHON_INTERPRETER_CFLAGS="`$pyprefix-config --cflags --embed` -DPY_SSIZE_T_CLEAN"
LIBPYTHON_INTERPRETER_LIBS=`$pyprefix-config --libs --embed`
LIBPYTHON_ABI_FLAGS=`$pyprefix-config --abiflags`
pythondep=$pyprefix