summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2018-08-31 19:15:26 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2018-08-31 19:15:26 (GMT)
commit531be2e3a96bf13cd36035cec7faa31b2534a742 (patch)
treed8c2b5f6d5601a1adfa7356f45879bb5f0fca348 /configure.ac
parent1307580ca1ca820b57dcfbfcdcee9afe74cc1614 (diff)
Changed the location of installed plugins.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 10 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 3eebab2..0d48687 100644
--- a/configure.ac
+++ b/configure.ac
@@ -98,7 +98,8 @@ AH_TEMPLATE([REVISION], [Define the version number of the program for the about
AH_TEMPLATE([PACKAGE_SOURCE_DIR], [Define the directory where the code source is waiting for being compiled.])
AH_TEMPLATE([PIXMAPS_DIR], [Define the directory where the pictures will be installed.])
AH_TEMPLATE([THEMES_DIR], [Define the main directory where all themes will be installed.])
-AH_TEMPLATE([PLUGINS_DIR], [Define the directory where the plugins are installed.])
+AH_TEMPLATE([PLUGINS_LIB_DIR], [Define the directory where the plugin librairies are installed.])
+AH_TEMPLATE([PLUGINS_DATA_DIR], [Define the directory where the plugin data is installed.])
AH_TEMPLATE([LOCALE_DIR], [Define the directory where the message catalogs are installed.])
@@ -137,10 +138,15 @@ AC_SUBST(themesdir)
AC_DEFINE_UNQUOTED(THEMES_DIR, "${themesdir}")
-pluginsdir="${pkgdatadir}/plugins"
-AC_SUBST(pluginsdir)
+pluginslibdir="${libdir}/chrysalide/plugins"
+AC_SUBST(pluginslibdir)
-AC_DEFINE_UNQUOTED(PLUGINS_DIR, "${pluginsdir}")
+AC_DEFINE_UNQUOTED(PLUGINS_LIB_DIR, "${pluginslibdir}")
+
+pluginsdatadir="${pkgdatadir}/plugins"
+AC_SUBST(pluginsdatadir)
+
+AC_DEFINE_UNQUOTED(PLUGINS_DATA_DIR, "${pluginsdatadir}")
if test "x${prefix}" = "xNONE"; then
AC_DEFINE_UNQUOTED(LOCALE_DIR, "${ac_default_prefix}/share/locale")