summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2016-05-02 07:08:26 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2016-05-02 07:08:26 (GMT)
commit6489995bdc9ed50117fd38f5f261334daad63870 (patch)
tree7c10e2d9d52a2c5ce283d072449345920a599d7e /configure.ac
parent4a137929c72b76d076387cd7e9d0d597e93d1974 (diff)
Warned in case of missing analyzer/parser generator.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dc1118a..e8291b3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,9 @@ AC_PROG_INSTALL
AC_PROG_MAKE_SET
AC_PROG_LIBTOOL
+AC_PATH_PROG(YACC_INST, $YACC)
+AC_PATH_PROG(LEX_INST, $LEX)
+
#--- Checks for libraries
@@ -421,8 +424,24 @@ echo Available Python programming language........ : $python3_version
echo The Python GObject bindings.................. : $libpygobject_version
echo
+echo Found lexical analyzer generator............. : $LEX_INST
+echo Found general-purpose parser generator....... : $YACC_INST
+
+echo
echo Print debugging messages..................... : $enable_debug
+if test -z "$LEX_INST" -o -z "$YACC_INST"; then
+
+ echo
+
+ m4_define([flex_bison_warning],[m4_joinall([m4_newline([])],
+ [Only code from a release archive can be compiled without analyzer and parser generators.],
+ [If the sources come from a repository snapshot, please install all the requiered dependencies for the software.])])
+
+ AC_MSG_WARN([flex_bison_warning])
+
+fi
+
echo
echo configure complete, now type \'make\'
echo