summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2022-12-29 12:28:42 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2022-12-29 12:28:42 (GMT)
commit755acfaa09e08a355b29081b75f9d547d264ce53 (patch)
treea6333a192603d572fc3d51c9ca94d274acbf0bb6 /configure.ac
parent41db261acccf3494aa93b71a181cde9e8605a841 (diff)
Refactor Makefiles to exclude cURL on demand.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 22 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 62ccef5..492634b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -218,6 +218,10 @@ AC_ARG_ENABLE([gtk-support],
AS_HELP_STRING([--disable-gtk-support], [disable GTK support [default=no]]),
[], [enable_gtk_support=yes])
+AC_ARG_ENABLE([curl-support],
+ AS_HELP_STRING([--disable-curl-support], [disable cURL support [default=no]]),
+ [], [enable_curl_support=yes])
+
AC_ARG_ENABLE([python-bindings],
AS_HELP_STRING([--disable-python-bindings], [disable Python bindings [default=no]]),
[], [enable_python_bindings=yes])
@@ -328,7 +332,7 @@ AC_SUBST(DESKTOP_DATADIR)
#--- Checks for GTK 3.0 / GObject 2.0
-
+R
AM_CONDITIONAL([BUILD_GTK_SUPPORT], [test "x$enable_gtk_support" = "xyes"])
if test "x$BUILD_GTK_SUPPORT_TRUE" = "x"; then
@@ -448,6 +452,14 @@ AC_SUBST(LIBSSL_LIBS)
#--- Checks for libcurl
+AM_CONDITIONAL([BUILD_CURL_SUPPORT], [test "x$enable_curl_support" = "xyes"])
+
+if test "x$BUILD_CURL_SUPPORT_TRUE" = "x"; then
+ AC_DEFINE(HAVE_CURL_SUPPORT, 1,
+ [Define to 1 if the cURL support is available and enabled.])
+fi
+
+
PKG_CHECK_MODULES(LIBCURL,libcurl >= 7.64,[libcurl_found=yes],[libcurl_found=no])
if test "$libcurl_found" = "yes"; then
@@ -456,8 +468,14 @@ else
libcurl_version='-'
fi
-AC_SUBST(LIBCURL_CFLAGS)
-AC_SUBST(LIBCURL_LIBS)
+if test "x$enable_curl_support" = "xyes"; then
+
+ AC_SUBST(LIBCURL_CFLAGS)
+ AC_SUBST(LIBCURL_LIBS)
+
+ true # empty if/then body not allowed
+
+fi
#--- Checks for Python
@@ -725,6 +743,7 @@ echo
echo Print debugging messages..................... : $enable_debug
echo Consider local resources..................... : $with_local_resources
echo Disable GTK support.......................... : $disable_gtk_support
+echo Disable cURL support......................... : $disable_curl_support
echo Disable Python bindings...................... : $disable_python_bindings
echo Build a Python binary distribution........... : $build_python_package