summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2024-08-25 17:03:08 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2024-08-25 17:03:08 (GMT)
commita0532508524a37444d15b878c5e494cd348b0cae (patch)
tree8b3d06e52123e953cd937501a7ea5d0d46461a6e /configure.ac
parent41dcf8a45d61108fef1f545ecdee5d79d8135089 (diff)
Include support for the JSON format.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6bf6ca1..13288b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -587,6 +587,20 @@ AC_SUBST(LIBHS_CFLAGS)
AC_SUBST(LIBHS_LIBS)
+#--- Checks for json-glib-1.0
+
+PKG_CHECK_MODULES(LIBJSONGLIB,json-glib-1.0 >= 1.6.6,[libjsonglib_found=yes],[libjsonglib_found=no])
+
+if test "$libjsonglib_found" = "yes"; then
+ libjsonglib_version=`pkg-config json-glib-1.0 --modversion`
+else
+ libjsonglib_version='-'
+fi
+
+AC_SUBST(LIBJSONGLIB_CFLAGS)
+AC_SUBST(LIBJSONGLIB_LIBS)
+
+
#--- Checks for Python
if test "x$enable_debug" = "xyes"; then
@@ -873,6 +887,7 @@ echo The client URL library....................... : $libcurl_version
echo The YAML support library..................... : $libyaml_version
echo The magic number recognition library......... : $libmagic_version
echo The high-performance matching library........ : $libhs_version
+echo The JSON Parser for GLib library............. : $libjsonglib_version
echo
echo Available Python programming language........ : $python3_version