summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2023-09-10 22:02:21 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2023-09-10 22:02:21 (GMT)
commitb370370a9e35f9dd2357102b17338d3d93bb62aa (patch)
treeb8a8c5019a0705a75cf9cf8572c07219bc159076 /configure.ac
parent2424c52c4f3bc44ce5f36348442cfa103e0989c2 (diff)
Tune the compilation using flags instead of a config file.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 2f35cbe..3501617 100644
--- a/configure.ac
+++ b/configure.ac
@@ -297,8 +297,8 @@ fi
AM_CONDITIONAL([TRACK_GOBJECT_LEAKS], [test "x$with_gobject_leak_tracker" = "xyes"])
if test "x$with_gobject_leak_tracker" = "xyes"; then
- AC_DEFINE(TRACK_GOBJECT_LEAKS, 1,
- [Define to 1 to enable code for dumping remaining GObject instances at exit.])
+ # Enable code for dumping remaining GObject instances at exit
+ CPPFLAGS="$CPPFLAGS -DTRACK_GOBJECT_LEAKS"
enable_debug="yes"
fi
@@ -351,8 +351,8 @@ R
AM_CONDITIONAL([BUILD_GTK_SUPPORT], [test "x$enable_gtk_support" = "xyes"])
if test "x$BUILD_GTK_SUPPORT_TRUE" = "x"; then
- AC_DEFINE(HAVE_GTK_SUPPORT, 1,
- [Define to 1 if the GTK support is available and enabled.])
+ # GTK support is available and enabled
+ CPPFLAGS="$CPPFLAGS -DINCLUDE_GTK_SUPPORT"
fi
@@ -470,8 +470,8 @@ AC_SUBST(LIBSSL_LIBS)
AM_CONDITIONAL([BUILD_CURL_SUPPORT], [test "x$enable_curl_support" = "xyes"])
if test "x$BUILD_CURL_SUPPORT_TRUE" = "x"; then
- AC_DEFINE(HAVE_CURL_SUPPORT, 1,
- [Define to 1 if the cURL support is available and enabled.])
+ # cURL support is available and enabled
+ CPPFLAGS="$CPPFLAGS -DINCLUDE_CURL_SUPPORT"
fi
@@ -512,8 +512,8 @@ AC_SUBST(LIBYAML_LIBS)
AM_CONDITIONAL([BUILD_MAGIC_SUPPORT], [test "x$enable_magic_support" = "xyes"])
if test "x$BUILD_MAGIC_SUPPORT_TRUE" = "x"; then
- AC_DEFINE(HAVE_MAGIC_SUPPORT, 1,
- [Define to 1 if the magic support is available and enabled.])
+ # Magic support is available and enabled
+ CPPFLAGS="$CPPFLAGS -DINCLUDE_MAGIC_SUPPORT"
fi
@@ -547,8 +547,8 @@ fi
AM_CONDITIONAL([BUILD_PYTHON3_BINDINGS], [test "x$enable_python_bindings$python3_cfg_binary" = "xyesyes"])
if test "x$BUILD_PYTHON3_BINDINGS_TRUE" = "x"; then
- AC_DEFINE(HAVE_PYTHON3_BINDINGS, 1,
- [Define to 1 if the Python bindings are available and enabled.])
+ # Python bindings are available and enabled
+ CPPFLAGS="$CPPFLAGS -DINCLUDE_PYTHON3_BINDINGS"
fi
if test "x$python3_cfg_binary" = "xyes"; then