summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2019-03-23 09:01:30 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2019-03-23 09:01:30 (GMT)
commitfd0df8f884336fc69bd0938453f9712c166f08c8 (patch)
treef24313aa72a50d41b8076cf6b257129530bf562e /configure.ac
parent03d5e6abfce49d4a18bbf70cbbaa3be8c58bf5b4 (diff)
Removed references to local sources if required.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 25 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index a2d8b5e..d1a14a2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -138,16 +138,29 @@ AC_SUBST(themesdir)
AC_DEFINE_UNQUOTED(THEMES_DIR, "${themesdir}")
-pluginslibdir="${libdir}/chrysalide/plugins"
-AC_SUBST(pluginslibdir)
-
-AC_DEFINE_UNQUOTED(PLUGINS_LIB_DIR, "${pluginslibdir}")
-
pluginsdatadir="${pkgdatadir}/plugins"
AC_SUBST(pluginsdatadir)
AC_DEFINE_UNQUOTED(PLUGINS_DATA_DIR, "${pluginsdatadir}")
+if test "x${libdir}" = 'x${exec_prefix}/lib'; then
+ if test "x${exec_prefix}" = "xNONE"; then
+ if test "x${prefix}" = "xNONE"; then
+ pluginslibdir="${ac_default_prefix}/lib/chrysalide/plugins"
+ else
+ pluginslibdir="${prefix}/lib/chrysalide/plugins"
+ fi
+ else
+ pluginslibdir="${exec_prefix}/lib/chrysalide/plugins"
+ fi
+else
+ pluginslibdir="${libdir}/chrysalide/plugins"
+fi
+
+AC_SUBST(pluginslibdir)
+
+AC_DEFINE_UNQUOTED(PLUGINS_LIB_DIR, "${pluginslibdir}")
+
if test "x${prefix}" = "xNONE"; then
AC_DEFINE_UNQUOTED(LOCALE_DIR, "${ac_default_prefix}/share/locale")
else
@@ -198,10 +211,16 @@ fi
#--- Discard local sources when looking for resources ?
+if test "x$enable_rpath" = "xno"; then
+ hardcode_libdir_flag_spec=
+fi
+
if test "x$with_local_resources" = "xno"; then
CFLAGS="$CFLAGS -DDISCARD_LOCAL"
fi
+AM_CONDITIONAL([BUILD_DISCARD_LOCAL], [test "x$with_local_resources" = "xno"])
+
AC_SUBST(CFLAGS)
#--- Compilation warnings
@@ -501,6 +520,7 @@ echo Found general-purpose parser generator....... : $YACC_INST
echo
echo Print debugging messages..................... : $enable_debug
+echo Consider local resources..................... : $with_local_resources
if test -z "$LEX_INST" -o -z "$YACC_INST"; then