summaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2022-12-29 11:02:46 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2022-12-29 11:02:46 (GMT)
commit41db261acccf3494aa93b71a181cde9e8605a841 (patch)
tree07a00f88920a8e601268d415131630052ef85988 /plugins/Makefile.am
parentc27f884ec1d18d9cff0d19d6ba8de1dd54d991c4 (diff)
Refactor Makefiles to exclude GTK on demand.
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 8d39c37..be0bd88 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -5,6 +5,12 @@ PYTHON3_SUBDIRS = pychrysalide python
endif
+if BUILD_GTK_SUPPORT
+
+ROPGADGETS_SUBDIRS = ropgadgets
+
+endif
+
# androhelpers
SUBDIRS = \
$(PYTHON3_SUBDIRS) \
@@ -28,5 +34,5 @@ SUBDIRS = \
readdex \
readelf \
readmc \
- ropgadgets \
+ $(ROPGADGETS_SUBDIRS) \
winordinals