summaryrefslogtreecommitdiff
path: root/plugins/apihashing/python/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2023-10-04 06:32:57 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2023-10-04 06:32:57 (GMT)
commit945aa5096d3c6d2ae054b6c8ef18e749acaec533 (patch)
treea76ca8a1c9303dfde49493d83d848e66c5a7d678 /plugins/apihashing/python/Makefile.am
parent29fd2d9d148f1737ff0dede043c9dc376116b3a4 (diff)
Introduce a new plugin for computing API hashes.
Diffstat (limited to 'plugins/apihashing/python/Makefile.am')
-rw-r--r--plugins/apihashing/python/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/plugins/apihashing/python/Makefile.am b/plugins/apihashing/python/Makefile.am
new file mode 100644
index 0000000..d94218d
--- /dev/null
+++ b/plugins/apihashing/python/Makefile.am
@@ -0,0 +1,20 @@
+
+noinst_LTLIBRARIES = libapihashingpython.la
+
+libapihashingpython_la_SOURCES = \
+ apihash.h apihash.c \
+ module.h module.c
+
+libapihashingpython_la_LIBADD = \
+ classics/libapihashingpythonclassics.la
+
+libapihashingpython_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) $(LIBPYTHON_CFLAGS) $(LIBPYGOBJECT_CFLAGS) \
+ -I$(top_srcdir)/src -DNO_IMPORT_PYGOBJECT
+
+
+devdir = $(includedir)/chrysalide/$(subdir)
+
+dev_HEADERS = $(libapihashingpython_la_SOURCES:%c=)
+
+
+SUBDIRS = classics