summaryrefslogtreecommitdiff
path: root/plugins/arm/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2019-02-04 18:45:19 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2019-02-04 18:45:19 (GMT)
commitff187d24b7441e88e1f0361d59b0f6f55851791f (patch)
treee340d88fb8189ef79f2c2d4193eea97be4fa003e /plugins/arm/Makefile.am
parent9b35b89fce2499d5352f5323baec53abbf9a4af2 (diff)
Added an option to drop Python support at compilation time.
Diffstat (limited to 'plugins/arm/Makefile.am')
-rw-r--r--plugins/arm/Makefile.am23
1 files changed, 17 insertions, 6 deletions
diff --git a/plugins/arm/Makefile.am b/plugins/arm/Makefile.am
index 12e58fd..3091db7 100644
--- a/plugins/arm/Makefile.am
+++ b/plugins/arm/Makefile.am
@@ -4,6 +4,18 @@ lib_LTLIBRARIES = libarm.la
libdir = $(pluginslibdir)
+if BUILD_PYTHON3_BINDINGS
+
+PYTHON3_LIBADD = python/libarmpython.la
+
+PYTHON3_LDFLAGS = -Wl,-rpath,$(abs_top_srcdir)/plugins/pychrysalide/.libs \
+ -L$(top_srcdir)/plugins/pychrysalide/.libs -l:pychrysalide.so
+
+PYTHON3_SUBDIRS = python
+
+endif
+
+
libarm_la_SOURCES = \
cond.h \
context-int.h \
@@ -18,13 +30,12 @@ libarm_la_SOURCES = \
register.h register.c
libarm_la_LIBADD = \
- python/libarmpython.la \
+ $(PYTHON3_LIBADD) \
v7/libarmv7.la
-libarm_la_LDFLAGS = \
- -L$(top_srcdir)/src/.libs -lchrysacore \
- -Wl,-rpath,$(abs_top_srcdir)/plugins/pychrysalide/.libs \
- -L$(top_srcdir)/plugins/pychrysalide/.libs -l:pychrysalide.so
+libarm_la_LDFLAGS = \
+ -L$(top_srcdir)/src/.libs -lchrysacore \
+ $(PYTHON3_LDFLAGS)
devdir = $(includedir)/chrysalide-$(subdir)
@@ -37,4 +48,4 @@ AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-SUBDIRS = v7 python
+SUBDIRS = v7 $(PYTHON3_SUBDIRS)