summaryrefslogtreecommitdiff
path: root/plugins/arm/v7/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2017-12-02 11:04:35 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2017-12-02 11:04:35 (GMT)
commit2c988d3ec52cc4c949a35aca7ef335dac773df92 (patch)
treefe650d2fc8ddceb606abdf0d2e14e5ef6596be82 /plugins/arm/v7/Makefile.am
parent23abef53590bf3dd6f88ff4dbe81e306abfa4386 (diff)
Created a plugin for the ARM support.
Diffstat (limited to 'plugins/arm/v7/Makefile.am')
-rw-r--r--plugins/arm/v7/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/plugins/arm/v7/Makefile.am b/plugins/arm/v7/Makefile.am
new file mode 100644
index 0000000..e2fc96c
--- /dev/null
+++ b/plugins/arm/v7/Makefile.am
@@ -0,0 +1,33 @@
+
+noinst_LTLIBRARIES = libarmv7.la
+
+libarmv7_la_SOURCES = \
+ arm.h arm.c \
+ context.h context.c \
+ core.h core.c \
+ cregister.h cregister.c \
+ fetch.h fetch.c \
+ helpers.h helpers.c \
+ instruction.h instruction.c \
+ link.h link.c \
+ post.h post.c \
+ processor.h processor.c \
+ pseudo.h pseudo.c \
+ register.h register.c \
+ simd.h simd.c \
+ thumb_16.h thumb_16.c \
+ thumb_32.h thumb_32.c
+
+libarmv7_la_LIBADD = \
+ opcodes/libarmv7opcodes.la \
+ operands/libarmv7operands.la
+
+libarmv7_la_CFLAGS = $(AM_CFLAGS)
+
+
+AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
+
+
+SUBDIRS = opdefs opcodes operands