summaryrefslogtreecommitdiff
path: root/plugins/arm/v7/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2018-05-28 17:37:46 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2018-05-28 17:37:46 (GMT)
commit9f5ed46de568d3db882c939c8ca9d0117bff3369 (patch)
tree9d2090cd640e54379dc1b982e03dc284b2d23ae7 /plugins/arm/v7/Makefile.am
parent2fd186a84cba4f39f6f1bb8bd34d52b4e1d4f814 (diff)
Relied on register objects as often as possible.
Diffstat (limited to 'plugins/arm/v7/Makefile.am')
-rw-r--r--plugins/arm/v7/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/plugins/arm/v7/Makefile.am b/plugins/arm/v7/Makefile.am
index 1ce4b01..5c98f7c 100644
--- a/plugins/arm/v7/Makefile.am
+++ b/plugins/arm/v7/Makefile.am
@@ -5,7 +5,6 @@ libarmv7_la_SOURCES = \
arm.h arm.c \
context.h context.c \
core.h core.c \
- cregister.h cregister.c \
fetch.h fetch.c \
helpers.h \
instruction.h instruction.c \
@@ -13,6 +12,7 @@ libarmv7_la_SOURCES = \
post.h post.c \
processor.h processor.c \
pseudo.h pseudo.c \
+ register-int.h \
register.h register.c \
simd.h simd.c \
thumb_16.h thumb_16.c \
@@ -20,7 +20,8 @@ libarmv7_la_SOURCES = \
libarmv7_la_LIBADD = \
opcodes/libarmv7opcodes.la \
- operands/libarmv7operands.la
+ operands/libarmv7operands.la \
+ registers/libarmv7registers.la
libarmv7_la_CFLAGS = $(AM_CFLAGS)