summaryrefslogtreecommitdiff
path: root/plugins/arm/v7/opdefs/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2018-05-31 16:24:27 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2018-05-31 16:24:27 (GMT)
commit48b4166d1f2931fa7f311b6ec1c77153052e63a0 (patch)
treeae00744c32653ac8196b51f7060d00283071cf4f /plugins/arm/v7/opdefs/Makefile.am
parentc492a5c94cc20210bce8069db7235cbb7dd691e9 (diff)
Handled lists of simples ARMv7 SIMD registers.
Diffstat (limited to 'plugins/arm/v7/opdefs/Makefile.am')
-rw-r--r--plugins/arm/v7/opdefs/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/plugins/arm/v7/opdefs/Makefile.am b/plugins/arm/v7/opdefs/Makefile.am
index 877f27d..59b69a4 100644
--- a/plugins/arm/v7/opdefs/Makefile.am
+++ b/plugins/arm/v7/opdefs/Makefile.am
@@ -349,6 +349,15 @@ ARMV7_DEFS = \
A88317_vfm.d \
A88318_vfnm.d \
A88319_vh.d \
+ A88320_vld1.d \
+ A88322_vld1.d \
+ A88323_vld2.d \
+ A88325_vld2.d \
+ A88326_vld3.d \
+ A88328_vld3.d \
+ A88329_vld4.d \
+ A88331_vld4.d \
+ A88332_vldm.d \
A88334_vmax.d \
A88335_vmax.d \
A88336_vmla.d \
@@ -375,6 +384,8 @@ ARMV7_DEFS = \
A88364_vpaddl.d \
A88365_vpmax.d \
A88366_vpmax.d \
+ A88367_vpop.d \
+ A88368_vpush.d \
A88369_vqabs.d \
A88370_vqadd.d \
A88374_vqmov.d \
@@ -393,12 +404,18 @@ ARMV7_DEFS = \
A88394_vrsubhn.d \
A88396_vshl.d \
A88401_vsqrt.d \
+ A88404_vst1.d \
+ A88406_vst2.d \
+ A88408_vst3.d \
+ A88410_vst4.d \
+ A88412_vstm.d \
A88413_vstr.d \
A88414_vsub.d \
A88415_vsub.d \
A88416_vsubhn.d \
A88417_vsub.d \
A88418_vswp.d \
+ A88419_vtb.d \
A88420_vtrn.d \
A88421_vtst.d \
A88422_vuzp.d \