summaryrefslogtreecommitdiff
path: root/plugins/bhash/python/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2021-04-06 22:55:54 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2021-04-06 22:55:54 (GMT)
commitc12d6a5d11bf9a2436ff78e393173ca59b6c9c46 (patch)
treeb579b642e301f5d6e6d88fb0213a54db6bf6fd38 /plugins/bhash/python/Makefile.am
parentc4d2e0fa48eab453d5c43a3c0938427617449a6a (diff)
Provide several kinds of hashes for binary files.
Diffstat (limited to 'plugins/bhash/python/Makefile.am')
-rw-r--r--plugins/bhash/python/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/plugins/bhash/python/Makefile.am b/plugins/bhash/python/Makefile.am
new file mode 100644
index 0000000..822a716
--- /dev/null
+++ b/plugins/bhash/python/Makefile.am
@@ -0,0 +1,21 @@
+
+noinst_LTLIBRARIES = libbhashpython.la
+
+libbhashpython_la_SOURCES = \
+ imphash.h imphash.c \
+ module.h module.c \
+ tlsh.h tlsh.c \
+ rich.h rich.c
+
+libbhashpython_la_LDFLAGS =
+
+
+devdir = $(includedir)/chrysalide/$(subdir)
+
+dev_HEADERS = $(libbhashpython_la_SOURCES:%c=)
+
+
+AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) $(LIBPYTHON_CFLAGS) $(LIBPYGOBJECT_CFLAGS) \
+ -I$(top_srcdir)/src -DNO_IMPORT_PYGOBJECT
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)