summaryrefslogtreecommitdiff
path: root/plugins/bootimg/python/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2019-07-07 21:46:38 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2019-07-07 21:46:38 (GMT)
commit24f4b449d22c918d8f0e6c8fc059e0fa1fa485ff (patch)
tree0652f6fc72996447cb050fefb9daf6da43de999a /plugins/bootimg/python/Makefile.am
parent13a879ebcf58f3868c0275d84dd9886673c9e614 (diff)
Added support for Android boot images.
Diffstat (limited to 'plugins/bootimg/python/Makefile.am')
-rw-r--r--plugins/bootimg/python/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/plugins/bootimg/python/Makefile.am b/plugins/bootimg/python/Makefile.am
new file mode 100644
index 0000000..a79af4d
--- /dev/null
+++ b/plugins/bootimg/python/Makefile.am
@@ -0,0 +1,20 @@
+
+noinst_LTLIBRARIES = libbootimgpython.la
+
+libbootimgpython_la_SOURCES = \
+ format.h format.c \
+ module.h module.c \
+ translate.h translate.c
+
+libbootimgpython_la_LDFLAGS =
+
+
+devdir = $(includedir)/chrysalide-$(subdir)
+
+dev_HEADERS = $(libbootimgpython_la_SOURCES:%c=)
+
+
+AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) $(LIBPYTHON_CFLAGS) $(LIBPYGOBJECT_CFLAGS) \
+ -I$(top_srcdir)/src -DNO_IMPORT_PYGOBJECT
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)