summaryrefslogtreecommitdiff
path: root/plugins/dex/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2022-12-29 11:02:46 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2022-12-29 11:02:46 (GMT)
commit41db261acccf3494aa93b71a181cde9e8605a841 (patch)
tree07a00f88920a8e601268d415131630052ef85988 /plugins/dex/Makefile.am
parentc27f884ec1d18d9cff0d19d6ba8de1dd54d991c4 (diff)
Refactor Makefiles to exclude GTK on demand.
Diffstat (limited to 'plugins/dex/Makefile.am')
-rw-r--r--plugins/dex/Makefile.am28
1 files changed, 13 insertions, 15 deletions
diff --git a/plugins/dex/Makefile.am b/plugins/dex/Makefile.am
index 8eb7bde..a587fe2 100644
--- a/plugins/dex/Makefile.am
+++ b/plugins/dex/Makefile.am
@@ -35,21 +35,23 @@ PYTHON3_SUBDIRS = python
endif
-libdex_la_SOURCES = \
- core.h core.c \
- class.h class.c \
- dex-int.h dex-int.c \
- dex_def.h \
- field.h field.c \
- format.h format.c \
- loading.h loading.c \
- method.h method.c \
- pool.h pool.c \
+libdex_la_SOURCES = \
+ core.h core.c \
+ class.h class.c \
+ dex-int.h dex-int.c \
+ dex_def.h \
+ field.h field.c \
+ format.h format.c \
+ loading.h loading.c \
+ method.h method.c \
+ pool.h pool.c \
routine.h routine.c
-libdex_la_LIBADD = \
+libdex_la_LIBADD = \
$(PYTHON3_LIBADD)
+libdex_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
+
libdex_la_LDFLAGS = \
-avoid-version \
-L$(top_srcdir)/src/.libs -lchrysacore \
@@ -61,8 +63,4 @@ devdir = $(includedir)/chrysalide/$(subdir)
dev_HEADERS = $(libdex_la_SOURCES:%c=)
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
-
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-
SUBDIRS = $(PYTHON3_SUBDIRS)