summaryrefslogtreecommitdiff
path: root/plugins/dexbnf/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2018-03-11 21:57:05 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2018-03-11 21:57:05 (GMT)
commit8088f1cbb4304c686ff41520099707a333084a4e (patch)
tree147411c3f90097dc1ae950ec390df2dfccf07ad7 /plugins/dexbnf/Makefile.am
parenta33dd28e763e3a8b04145fb549aca9320e100a4b (diff)
Defined a new Dex demangler with MUTF-8 support as plugin.
Diffstat (limited to 'plugins/dexbnf/Makefile.am')
-rw-r--r--plugins/dexbnf/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/plugins/dexbnf/Makefile.am b/plugins/dexbnf/Makefile.am
new file mode 100644
index 0000000..08e0680
--- /dev/null
+++ b/plugins/dexbnf/Makefile.am
@@ -0,0 +1,27 @@
+
+lib_LTLIBRARIES = libdexbnf.la
+
+libdir = $(pluginsdir)
+
+libdexbnf_la_SOURCES = \
+ context.h context.c \
+ core.h core.c \
+ demangler.h demangler.c \
+ simple.h simple.c \
+ shorty.h shorty.c \
+ type.h type.c
+
+libdexbnf_la_CFLAGS = $(AM_CFLAGS)
+
+libdexbnf_la_LIBADD = \
+ python/libdexbnfpython.la
+
+libdexbnf_la_LDFLAGS = \
+ $(LIBPYTHON_LIBS) $(LIBPYGOBJECT_LIBS)
+
+
+AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
+
+SUBDIRS = python