summaryrefslogtreecommitdiff
path: root/plugins/dexbnf/python/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2018-03-11 21:57:05 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2018-03-11 21:57:05 (GMT)
commit8088f1cbb4304c686ff41520099707a333084a4e (patch)
tree147411c3f90097dc1ae950ec390df2dfccf07ad7 /plugins/dexbnf/python/Makefile.am
parenta33dd28e763e3a8b04145fb549aca9320e100a4b (diff)
Defined a new Dex demangler with MUTF-8 support as plugin.
Diffstat (limited to 'plugins/dexbnf/python/Makefile.am')
-rw-r--r--plugins/dexbnf/python/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/plugins/dexbnf/python/Makefile.am b/plugins/dexbnf/python/Makefile.am
new file mode 100644
index 0000000..4d60a1c
--- /dev/null
+++ b/plugins/dexbnf/python/Makefile.am
@@ -0,0 +1,15 @@
+
+noinst_LTLIBRARIES = libdexbnfpython.la
+
+libdexbnfpython_la_SOURCES = \
+ demangler.h demangler.c \
+ module.h module.c
+
+
+libdexbnfpython_la_LDFLAGS =
+
+
+AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) $(LIBPYTHON_CFLAGS) $(LIBPYGOBJECT_CFLAGS) \
+ -I$(top_srcdir)/src
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)