summaryrefslogtreecommitdiff
path: root/plugins/elf/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2017-10-01 17:32:12 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2017-10-01 17:32:12 (GMT)
commit208abfe4182c0dafc230e0377b3efcc6c24be0f9 (patch)
tree4e084364b0a211ee36a5e8e55b70367f01d720d5 /plugins/elf/Makefile.am
parent593aee561015251dfd042dc5e00388f63232c45f (diff)
Defined the ELF support as plugin.
Diffstat (limited to 'plugins/elf/Makefile.am')
-rw-r--r--plugins/elf/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/plugins/elf/Makefile.am b/plugins/elf/Makefile.am
new file mode 100644
index 0000000..d3cfe05
--- /dev/null
+++ b/plugins/elf/Makefile.am
@@ -0,0 +1,29 @@
+
+lib_LTLIBRARIES = libelf.la
+
+libelf_la_SOURCES = \
+ core.h core.c \
+ elf-int.h elf-int.c \
+ elf.h elf.c \
+ elf_def.h \
+ elf_def_arm.h \
+ dynamic.h dynamic.c \
+ helper_arm.h helper_arm.c \
+ loading.h loading.c \
+ program.h program.c \
+ section.h section.c \
+ strings.h strings.c \
+ symbols.h symbols.c
+
+libelf_la_LIBADD = \
+ python/libelfpython.la
+
+libelf_la_LDFLAGS = \
+ $(LIBPYTHON_LIBS) $(LIBPYGOBJECT_LIBS)
+
+
+AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBPYTHON_CFLAGS) $(LIBPYGOBJECT_CFLAGS) $(LIBXML_CFLAGS) -I../../src
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
+
+SUBDIRS = python