summaryrefslogtreecommitdiff
path: root/plugins/elf/python/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2017-10-01 17:32:12 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2017-10-01 17:32:12 (GMT)
commit208abfe4182c0dafc230e0377b3efcc6c24be0f9 (patch)
tree4e084364b0a211ee36a5e8e55b70367f01d720d5 /plugins/elf/python/Makefile.am
parent593aee561015251dfd042dc5e00388f63232c45f (diff)
Defined the ELF support as plugin.
Diffstat (limited to 'plugins/elf/python/Makefile.am')
-rw-r--r--plugins/elf/python/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/plugins/elf/python/Makefile.am b/plugins/elf/python/Makefile.am
new file mode 100644
index 0000000..4de3e3c
--- /dev/null
+++ b/plugins/elf/python/Makefile.am
@@ -0,0 +1,15 @@
+
+noinst_LTLIBRARIES = libelfpython.la
+
+libelfpython_la_SOURCES = \
+ elf.h elf.c \
+ module.h module.c
+
+
+libelfpython_la_LDFLAGS =
+
+
+AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) $(LIBPYTHON_CFLAGS) $(LIBPYGOBJECT_CFLAGS) \
+ -I../../../src -I../../..
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)