summaryrefslogtreecommitdiff
path: root/plugins/java/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2018-12-07 21:04:46 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2018-12-07 21:04:46 (GMT)
commit648bf475951e6d588d13539441d8a0e54eab2706 (patch)
treeb654558a0c6bb4bc9d15eb9d65c124acb8a3522a /plugins/java/Makefile.am
parentc980546e8bca6f1c0c340634a4c3640e14fd1228 (diff)
Moved some core features into plugins.
Diffstat (limited to 'plugins/java/Makefile.am')
-rw-r--r--plugins/java/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/plugins/java/Makefile.am b/plugins/java/Makefile.am
new file mode 100644
index 0000000..0e40bfa
--- /dev/null
+++ b/plugins/java/Makefile.am
@@ -0,0 +1,29 @@
+
+noinst_LTLIBRARIES = libformatjava.la
+
+libformatjava_la_SOURCES = \
+ java-int.h java-int.c \
+ java.h java.c \
+ java_def.h \
+ pool.h pool.c
+
+
+# libformatjava_la_SOURCES = \
+# attribute.h attribute.c \
+# e_java.h e_java.c \
+# field.h field.c \
+# java-int.h \
+# method.h method.c \
+# pool.h pool.c
+
+libformatjava_la_LDFLAGS =
+
+
+devdir = $(includedir)/chrysalide/$(subdir:src/%=%)
+
+dev_HEADERS = $(libformatjava_la_SOURCES:%c=)
+
+
+AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS)
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)