summaryrefslogtreecommitdiff
path: root/plugins/javadesc/python/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2018-12-04 22:49:03 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2018-12-04 22:49:03 (GMT)
commite146d7d8c7af50d2592379570c66acaf1dfa73c9 (patch)
tree31f20677a1a46427383080cba0c8f61652c8f51c /plugins/javadesc/python/Makefile.am
parent9e58f9ae7208eeaf09a4b0af2f60996341d6af50 (diff)
Updated the Java descriptor demangling process.
Diffstat (limited to 'plugins/javadesc/python/Makefile.am')
-rw-r--r--plugins/javadesc/python/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/plugins/javadesc/python/Makefile.am b/plugins/javadesc/python/Makefile.am
new file mode 100644
index 0000000..06deb3d
--- /dev/null
+++ b/plugins/javadesc/python/Makefile.am
@@ -0,0 +1,19 @@
+
+noinst_LTLIBRARIES = libjavadescpython.la
+
+libjavadescpython_la_SOURCES = \
+ demangler.h demangler.c \
+ module.h module.c
+
+libjavadescpython_la_LDFLAGS =
+
+
+devdir = $(includedir)/chrysalide-$(subdir)
+
+dev_HEADERS = $(libjavadescpython_la_SOURCES:%c=)
+
+
+AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) $(LIBPYTHON_CFLAGS) $(LIBPYGOBJECT_CFLAGS) \
+ -I$(top_srcdir)/src -DNO_IMPORT_PYGOBJECT
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)