summaryrefslogtreecommitdiff
path: root/plugins/lnxsyscalls/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2022-12-29 11:02:46 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2022-12-29 11:02:46 (GMT)
commit41db261acccf3494aa93b71a181cde9e8605a841 (patch)
tree07a00f88920a8e601268d415131630052ef85988 /plugins/lnxsyscalls/Makefile.am
parentc27f884ec1d18d9cff0d19d6ba8de1dd54d991c4 (diff)
Refactor Makefiles to exclude GTK on demand.
Diffstat (limited to 'plugins/lnxsyscalls/Makefile.am')
-rw-r--r--plugins/lnxsyscalls/Makefile.am25
1 files changed, 9 insertions, 16 deletions
diff --git a/plugins/lnxsyscalls/Makefile.am b/plugins/lnxsyscalls/Makefile.am
index 9c5158f..21feaa5 100644
--- a/plugins/lnxsyscalls/Makefile.am
+++ b/plugins/lnxsyscalls/Makefile.am
@@ -14,17 +14,17 @@ RUN_PATH = -Wl,-rpath,'$$ORIGIN'
endif
-liblnxsyscalls_la_SOURCES = \
- collect.h collect.c \
- core.h core.c \
- db.h db.c \
- hops.h \
- hops_armv7.h hops_armv7.c \
- hunter.h hunter.c \
- syscall.h syscall.c \
+liblnxsyscalls_la_SOURCES = \
+ collect.h collect.c \
+ core.h core.c \
+ db.h db.c \
+ hops.h \
+ hops_armv7.h hops_armv7.c \
+ hunter.h hunter.c \
+ syscall.h syscall.c \
writer.h writer.c
-liblnxsyscalls_la_LIBADD =
+liblnxsyscalls_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
liblnxsyscalls_la_LDFLAGS = \
-avoid-version \
@@ -44,10 +44,3 @@ dbdir = $(pluginsdatadir)
devdir = $(includedir)/chrysalide/$(subdir)
dev_HEADERS = $(liblnxsyscalls_la_SOURCES:%c=)
-
-
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
-
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-
-SUBDIRS =