summaryrefslogtreecommitdiff
path: root/plugins/pe/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2021-01-17 22:31:39 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2021-04-05 23:00:11 (GMT)
commite35215675101a4a5b59fe080fcb6b2609daa6cd3 (patch)
tree60dddfb275fe80e79a16fc65811b49229e2d962f /plugins/pe/Makefile.am
parent636289c5397a81772a994fc5272d1fc0700a8026 (diff)
Moved PE code with its history.
Diffstat (limited to 'plugins/pe/Makefile.am')
-rw-r--r--plugins/pe/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/plugins/pe/Makefile.am b/plugins/pe/Makefile.am
new file mode 100644
index 0000000..00050a5
--- /dev/null
+++ b/plugins/pe/Makefile.am
@@ -0,0 +1,21 @@
+
+noinst_LTLIBRARIES = libformatpe.la
+
+libformatpe_la_SOURCES = \
+ pe-int.h pe-int.c \
+ pe.h pe.c \
+ pe_def.h \
+ section.h section.c \
+ symbols.h symbols.c
+
+libformatpe_la_LDFLAGS =
+
+
+devdir = $(includedir)/chrysalide/$(subdir:src/%=%)
+
+dev_HEADERS = $(libformatpe_la_SOURCES:%c=)
+
+
+AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS)
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)