summaryrefslogtreecommitdiff
path: root/plugins/yaml/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2023-04-27 21:27:52 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2023-04-27 21:27:52 (GMT)
commit25bac01127581767639a5bd9024c41eb803388fa (patch)
treea67cd5cdecbf001e788935e756fc722b7c552b9b /plugins/yaml/Makefile.am
parenta1ff7646ce6f829dd192e2e2246def2ea583e93b (diff)
Replace the old YAML parser by another one relying on the external libyaml library.
Diffstat (limited to 'plugins/yaml/Makefile.am')
-rw-r--r--plugins/yaml/Makefile.am12
1 files changed, 5 insertions, 7 deletions
diff --git a/plugins/yaml/Makefile.am b/plugins/yaml/Makefile.am
index 868fcf1..1165d7a 100644
--- a/plugins/yaml/Makefile.am
+++ b/plugins/yaml/Makefile.am
@@ -36,26 +36,24 @@ endif
libyaml_la_SOURCES = \
+ collection-int.h \
collection.h collection.c \
core.h core.c \
- line.h line.c \
node-int.h \
node.h node.c \
+ pair-int.h \
pair.h pair.c \
- reader-int.h \
- reader.h reader.c \
- scalar.h scalar.c \
- tree.h tree.c
+ parser.h parser.c
libyaml_la_LIBADD = \
$(PYTHON3_LIBADD)
-libyaml_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
+libyaml_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) $(LIBYAML_CFLAGS) -I$(top_srcdir)/src
libyaml_la_LDFLAGS = \
-avoid-version \
-L$(top_srcdir)/src/.libs -lchrysacore \
- $(RUN_PATH) $(PYTHON3_LDFLAGS)
+ $(RUN_PATH) $(LIBYAML_LIBS) $(PYTHON3_LDFLAGS)
devdir = $(includedir)/chrysalide/$(subdir)