summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2019-03-22 21:28:45 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2019-03-22 21:28:45 (GMT)
commit49052753583c9468853238d026ff36dd70e47723 (patch)
tree6806415d50994e75df4a1f6362e0f564eac27e77 /src/Makefile.am
parentc6c8ddc7823976f5751342ea5eb38c21465bd124 (diff)
Handled properly program dependencies.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 11157a4..a547084 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,8 +3,6 @@ lib_LTLIBRARIES = libchrysacore.la
bin_PROGRAMS = chrysalide csrvmng
-.NOTPARALLEL: $(lib_LTLIBRARIES) $(bin_PROGRAMS)
-
############################################################
@@ -38,10 +36,13 @@ libchrysacore_la_LIBADD = \
plugins/libplugins.la
+
############################################################
# Programme principal
############################################################
+EXTRA_chrysalide_DEPENDENCIES = $(lib_LTLIBRARIES)
+
chrysalide_SOURCES = \
main.c
@@ -63,6 +64,8 @@ chrysalide_LDADD = $(LIBINTL)
# Gestionnaire de serveurs distants
############################################################
+EXTRA_csrvmng_DEPENDENCIES = $(lib_LTLIBRARIES)
+
csrvmng_SOURCES = \
csrvmng.c