summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2019-02-06 18:40:49 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2019-02-06 18:40:49 (GMT)
commit7b3ca7accd4103bb5069d31b2389ea76c57846ca (patch)
treecdc9e63e83691131bcb427148edd340bd353d791 /src/Makefile.am
parent3e6da2a6085a2bc04dd5324f7ee74633a53543f3 (diff)
Introduced a tracker for GObjects leaks.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 31e1d72..ffa4bb5 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -35,7 +35,14 @@ libchrysacore_la_LIBADD = \
# Programme principal
############################################################
+if TRACK_GOBJECT_LEAKS
+
+GOBJECT_LEAKS_SOURCES = gleak.h gleak.c
+
+endif
+
chrysalide_SOURCES = \
+ $(GOBJECT_LEAKS_SOURCES) \
main.c