summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2009-05-11 23:42:48 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2009-05-11 23:42:48 (GMT)
commit96cb6971ee3ca529958b8cb1e8e55a6eb4e60eae (patch)
tree68e49f325de3e93ef186d3e078da8ddc473aedf7 /src/Makefile.am
parent80dc0ac97987ad9246bee7c47458a015339453bf (diff)
Reorganized the way the program is built again and added partial support for the JVM.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@63 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am32
1 files changed, 24 insertions, 8 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b7c2fa5..dd5d1ea 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,5 @@
-lib_LTLIBRARIES = liboidadisass.la liboidagtkext.la
+lib_LTLIBRARIES = liboidadisass.la liboidagtkext.la liboidagui.la liboidaplugin.la
bin_PROGRAMS=openida
@@ -19,13 +19,7 @@ liboidadisass_la_LDFLAGS = $(LIBGTK_LIBS) $(LIBXML_LIBS) \
liboidadisass_la_LIBADD = \
analysis/libanalysis.la \
arch/libarch.la \
- arch/x86/libarchx86.la \
- format/libformat.la \
- format/dwarf/libformatdwarf.la \
- format/elf/libformatelf.la \
- format/java/libformatjava.la \
- format/mangling/libformatmangling.la \
- format/pe/libformatpe.la
+ format/libformat.la
#--- liboidagtkext
@@ -39,6 +33,28 @@ liboidagtkext_la_LIBADD = \
gtkext/libgtkext.la
+#--- liboidagui
+
+liboidagui_la_SOURCES =
+
+liboidagui_la_LDFLAGS = $(LIBGTK_LIBS) \
+ -L.libs -loidagtkext
+
+liboidagui_la_LIBADD = \
+ panel/libpanel.la
+
+
+#--- liboidaplugin
+
+liboidaplugin_la_SOURCES =
+
+liboidaplugin_la_LDFLAGS = $(LIBGTK_LIBS) \
+ -L.libs -loidadisass -loidagui
+
+liboidaplugin_la_LIBADD = \
+ plugins/libplugins.la
+
+
############################################################
# Programme principal