summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2019-02-07 20:46:35 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2019-02-07 20:46:35 (GMT)
commitdbdd42585e8aa3333010bd57f0cd1129ac3c1d2f (patch)
treea84dddf8f782c70a4318b2304449b2f38b0b5544 /src/Makefile.am
parent3da6844c02f4041998ec655c19c7987e875adaf8 (diff)
Included the leak tracker into the Python interpreter.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ffa4bb5..11157a4 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -13,7 +13,14 @@ bin_PROGRAMS = chrysalide csrvmng
#--- libchrysacore
-libchrysacore_la_SOURCES =
+if TRACK_GOBJECT_LEAKS
+
+GOBJECT_LEAKS_SOURCES = gleak.h gleak.c
+
+endif
+
+libchrysacore_la_SOURCES = \
+ $(GOBJECT_LEAKS_SOURCES)
libchrysacore_la_LDFLAGS = $(LIBGTK_LIBS) $(LIBXML_LIBS) $(LIBSQLITE_LIBS) $(LIBARCHIVE_LIBS)
@@ -35,14 +42,7 @@ libchrysacore_la_LIBADD = \
# Programme principal
############################################################
-if TRACK_GOBJECT_LEAKS
-
-GOBJECT_LEAKS_SOURCES = gleak.h gleak.c
-
-endif
-
chrysalide_SOURCES = \
- $(GOBJECT_LEAKS_SOURCES) \
main.c