summaryrefslogtreecommitdiff
path: root/src/analysis/storage/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2020-07-07 21:52:13 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2020-07-07 21:52:13 (GMT)
commit6ea1b9a8550adf84cde510c2d4446c5120c4d065 (patch)
treef6b5838203e87be9dce04ae0771cb14e5bfdfb87 /src/analysis/storage/Makefile.am
parentd3c1294c05579db9dd5a1436883fe3fb78a052be (diff)
Saved the first steps toward a new serialization system.
Diffstat (limited to 'src/analysis/storage/Makefile.am')
-rw-r--r--src/analysis/storage/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/analysis/storage/Makefile.am b/src/analysis/storage/Makefile.am
new file mode 100644
index 0000000..94f5041
--- /dev/null
+++ b/src/analysis/storage/Makefile.am
@@ -0,0 +1,30 @@
+
+noinst_LTLIBRARIES = libanalysisstorage.la
+
+
+libanalysisstorage_la_SOURCES = \
+ cache-int.h \
+ cache.h cache.c \
+ container-int.h \
+ container.h container.c \
+ serialize-int.h \
+ serialize.h serialize.c \
+ storage-int.h \
+ storage.h storage.c \
+ tpmem.h tpmem.c
+
+libanalysisstorage_la_LIBADD =
+
+libanalysisstorage_la_LDFLAGS = $(LIBSSL_LIBS)
+
+
+devdir = $(includedir)/chrysalide/$(subdir:src/%=%)
+
+dev_HEADERS = $(libanalysisstorage_la_SOURCES:%c=)
+
+
+AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) $(LIBARCHIVE_CFLAGS) $(LIBSQLITE_CFLAGS) $(LIBSSL_CFLAGS)
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
+
+SUBDIRS =