summaryrefslogtreecommitdiff
path: root/src/arch/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2009-05-11 23:42:48 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2009-05-11 23:42:48 (GMT)
commit96cb6971ee3ca529958b8cb1e8e55a6eb4e60eae (patch)
tree68e49f325de3e93ef186d3e078da8ddc473aedf7 /src/arch/Makefile.am
parent80dc0ac97987ad9246bee7c47458a015339453bf (diff)
Reorganized the way the program is built again and added partial support for the JVM.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@63 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/arch/Makefile.am')
-rw-r--r--src/arch/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/src/arch/Makefile.am b/src/arch/Makefile.am
index da522df..1fb49a8 100644
--- a/src/arch/Makefile.am
+++ b/src/arch/Makefile.am
@@ -1,7 +1,10 @@
-lib_LTLIBRARIES = libarch.la
+noinst_LTLIBRARIES = libarch.la
libarch_la_SOURCES = \
+ archbase.h \
+ artificial.h artificial.c \
+ immediate.h immediate.c \
instruction-int.h \
instruction.h instruction.c \
operand-int.h \
@@ -9,7 +12,9 @@ libarch_la_SOURCES = \
processor-int.h \
processor.h processor.c
-libarch_la_LIBADD =
+libarch_la_LIBADD = \
+ jvm/libarchjvm.la \
+ x86/libarchx86.a
libarch_la_LDFLAGS =
@@ -21,4 +26,4 @@ AM_CPPFLAGS =
AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-SUBDIRS = x86
+SUBDIRS = jvm #x86