summaryrefslogtreecommitdiff
path: root/src/arch/arm/v7/opdefs/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2015-06-18 21:53:43 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2015-06-18 21:53:43 (GMT)
commit2bf52fcc65f066186b2b5ada7bad4d41770caf01 (patch)
tree86f04041e08416dcae9238eda47f089fc1bd1420 /src/arch/arm/v7/opdefs/Makefile.am
parentc987ca944052019957d3f31d69c679ed5ad994f2 (diff)
Fixed and extended the support for ARM v7 instructions.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@542 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/arch/arm/v7/opdefs/Makefile.am')
-rw-r--r--src/arch/arm/v7/opdefs/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/arch/arm/v7/opdefs/Makefile.am b/src/arch/arm/v7/opdefs/Makefile.am
index 6678f0e..6207906 100644
--- a/src/arch/arm/v7/opdefs/Makefile.am
+++ b/src/arch/arm/v7/opdefs/Makefile.am
@@ -54,8 +54,10 @@ ARMV7_DEFS = \
ldr_A8864.d \
ldr_A8865.d \
ldrb_A8867.d \
+ ldrb_A8868.d \
ldrb_A8870.d \
lsl_A8894.d \
+ lsr_A8896.d \
mla_A88100.d \
mls_A88101.d \
mov_A88102.d \
@@ -82,6 +84,7 @@ ARMV7_DEFS = \
str_A88203.d \
str_A88204.d \
strb_A88206.d \
+ strb_A88207.d \
strb_A88208.d \
sub_A88221.d \
sub_A88222.d \