summaryrefslogtreecommitdiff
path: root/src/arch/arm/v7/opdefs/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2015-04-01 21:45:29 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2015-04-01 21:45:29 (GMT)
commit3293a5b3b13271ea1499718d310c1bd0284762a3 (patch)
tree65f564c8fb56d1d28ac4da9ef62d65db06c29591 /src/arch/arm/v7/opdefs/Makefile.am
parent5cc7bd39ae41af40a0c939acf98f90bf1375effd (diff)
Fixed the definition of inner blocks by cutting at the right starting position.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@498 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/arch/arm/v7/opdefs/Makefile.am')
-rw-r--r--src/arch/arm/v7/opdefs/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/arch/arm/v7/opdefs/Makefile.am b/src/arch/arm/v7/opdefs/Makefile.am
index b95b588..b897f1d 100644
--- a/src/arch/arm/v7/opdefs/Makefile.am
+++ b/src/arch/arm/v7/opdefs/Makefile.am
@@ -106,7 +106,7 @@ fmk.done: $(ARMV7_DEFS)
fix_includes_in_c_templates:
@for f in `find .gen/ -name '*tmpl.c'`; do \
if grep -q '##INCLUDES##' $$f; then \
- $(fix_verbose)sed -i 's/##INCLUDES##/\n#include "..\/helpers.h"\n#include "..\/instruction.h"\n#include "..\/fetch.h"\n#include "..\/post.h"\n#include "..\/..\/instruction.h"\n#include "..\/..\/..\/link.h"\n#include "..\/..\/..\/..\/common\/bconst.h"\n\n/' $$f; \
+ $(fix_verbose)sed -i 's/##INCLUDES##/\n#include "..\/helpers.h"\n#include "..\/instruction.h"\n#include "..\/fetch.h"\n#include "..\/post.h"\n#include "..\/..\/instruction.h"\n#include "..\/..\/link.h"\n#include "..\/..\/..\/link.h"\n#include "..\/..\/..\/..\/common\/bconst.h"\n\n/' $$f; \
fi; \
done