summaryrefslogtreecommitdiff
path: root/src/arch/arm/v7/opdefs/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2014-12-02 21:51:13 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2014-12-02 21:51:13 (GMT)
commitc72f4d81bff9d6b8fa2317823a86742cb59e0544 (patch)
treedfa7dd5578eb5c347a6930c6578a5c7f27d2b2d5 /src/arch/arm/v7/opdefs/Makefile.am
parent5b5b36dc862a3c7bcfa3e0db74efcf2806988706 (diff)
Extended the compiler by allowing more than one type of Thumb.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@431 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/arch/arm/v7/opdefs/Makefile.am')
-rw-r--r--src/arch/arm/v7/opdefs/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/arch/arm/v7/opdefs/Makefile.am b/src/arch/arm/v7/opdefs/Makefile.am
index a8ae089..ad52bd2 100644
--- a/src/arch/arm/v7/opdefs/Makefile.am
+++ b/src/arch/arm/v7/opdefs/Makefile.am
@@ -11,7 +11,8 @@ D2C_HEADER = _ARCH_ARM_V7
D2C_ENCODINGS = \
-e a= \
- -e t=thumb_
+ -e t=thumb16_ \
+ -e T=thumb32_
D2C_MACROS = \
-M SetFlags=g_armv7_instruction_define_setflags \
@@ -39,6 +40,7 @@ ARMV7_DEFS = \
eor_A8847.d \
mla_A88100.d \
mls_A88101.d \
+ mov_A88102.d \
mov_A88104.d \
mul_A88114.d \
mvn_A88115.d \