summaryrefslogtreecommitdiff
path: root/src/arch/mips/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2009-05-31 20:58:20 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2009-05-31 20:58:20 (GMT)
commit8724afdc73e0ddad86f46de1a3fbe0254575a76e (patch)
treede666b66e154c6c6453807d3fa4272efb6877a91 /src/arch/mips/Makefile.am
parent0b7d7f26c745ff0f52e9e483a0980351368ca824 (diff)
Supported a new architecture (MIPS).
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@67 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/arch/mips/Makefile.am')
-rw-r--r--src/arch/mips/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/arch/mips/Makefile.am b/src/arch/mips/Makefile.am
new file mode 100644
index 0000000..7b25864
--- /dev/null
+++ b/src/arch/mips/Makefile.am
@@ -0,0 +1,30 @@
+
+noinst_LTLIBRARIES = libarchmips.la
+
+libarchmips_la_SOURCES = \
+ instruction.h instruction.c \
+ op_add.c \
+ op_and.c \
+ op_branch.c \
+ op_jump.c \
+ op_load.c \
+ op_nop.c \
+ op_sr.c \
+ op_store.c \
+ op_sub.c \
+ opcodes.h \
+ operand.h operand.c \
+ processor.h processor.c \
+ registers.h registers.c
+
+libarchmips_la_CFLAGS = $(AM_CFLAGS)
+
+
+INCLUDES = $(LIBGTK_CFLAGS)
+
+AM_CPPFLAGS =
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
+
+
+SUBDIRS =